summaryrefslogtreecommitdiffstats
path: root/toolkit/mozapps/macos-frameworks/ChannelPrefs
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-12 05:43:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-12 05:43:14 +0000
commit8dd16259287f58f9273002717ec4d27e97127719 (patch)
tree3863e62a53829a84037444beab3abd4ed9dfc7d0 /toolkit/mozapps/macos-frameworks/ChannelPrefs
parentReleasing progress-linux version 126.0.1-1~progress7.99u1. (diff)
downloadfirefox-8dd16259287f58f9273002717ec4d27e97127719.tar.xz
firefox-8dd16259287f58f9273002717ec4d27e97127719.zip
Merging upstream version 127.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'toolkit/mozapps/macos-frameworks/ChannelPrefs')
-rw-r--r--toolkit/mozapps/macos-frameworks/ChannelPrefs/ChannelPrefs.mm8
-rw-r--r--toolkit/mozapps/macos-frameworks/ChannelPrefs/Makefile.in23
2 files changed, 25 insertions, 6 deletions
diff --git a/toolkit/mozapps/macos-frameworks/ChannelPrefs/ChannelPrefs.mm b/toolkit/mozapps/macos-frameworks/ChannelPrefs/ChannelPrefs.mm
index f437bb857d..0428bbe8ab 100644
--- a/toolkit/mozapps/macos-frameworks/ChannelPrefs/ChannelPrefs.mm
+++ b/toolkit/mozapps/macos-frameworks/ChannelPrefs/ChannelPrefs.mm
@@ -6,7 +6,13 @@
#include "mozilla/HelperMacros.h"
+#ifdef MOZ_UPDATE_CHANNEL_OVERRIDE
+# define CHANNEL MOZ_UPDATE_CHANNEL_OVERRIDE
+#else
+# define CHANNEL MOZ_UPDATE_CHANNEL
+#endif
+
NSString* ChannelPrefsGetChannel() {
- return [NSString stringWithCString:MOZ_STRINGIFY(MOZ_UPDATE_CHANNEL)
+ return [NSString stringWithCString:MOZ_STRINGIFY(CHANNEL)
encoding:NSUTF8StringEncoding];
}
diff --git a/toolkit/mozapps/macos-frameworks/ChannelPrefs/Makefile.in b/toolkit/mozapps/macos-frameworks/ChannelPrefs/Makefile.in
index 43552a771e..7f3bfd1cc5 100644
--- a/toolkit/mozapps/macos-frameworks/ChannelPrefs/Makefile.in
+++ b/toolkit/mozapps/macos-frameworks/ChannelPrefs/Makefile.in
@@ -5,10 +5,23 @@
include $(topsrcdir)/config/rules.mk
+# In a compile build, the moz.build stanzas produce a binary named
+# `ChannelPrefs`. We need to produce
+# `dist/bin/ChannelPrefs.framework/ChannelPrefs` for consumption by the
+# build.
+#
+# In an artifact build, we copy upstream artifacts from
+# `dist/update_framework_artifacts/ChannelPrefs-localbuild.framework`
+
ifeq (cocoa,$(MOZ_WIDGET_TOOLKIT))
libs::
- rm -rf $(DIST)/bin/ChannelPrefs.framework
-
- $(NSINSTALL) $(DIST)/bin/ChannelPrefs $(DIST)/bin/ChannelPrefs.framework
- $(NSINSTALL) $(srcdir)/Info.plist $(DIST)/bin/ChannelPrefs.framework/Resources
-endif
+ rm -rf $(FINAL_TARGET)/ChannelPrefs.framework
+ $(NSINSTALL) -D $(FINAL_TARGET)/ChannelPrefs.framework
+ifneq (,$(COMPILE_ENVIRONMENT))
+ $(NSINSTALL) $(FINAL_TARGET)/ChannelPrefs $(FINAL_TARGET)/ChannelPrefs.framework
+endif # COMPILE_ENVIRONMENT
+ifneq (,$(MOZ_ARTIFACT_BUILDS))
+ $(NSINSTALL) $(DIST)/update_framework_artifacts/ChannelPrefs-localbuild.framework/ChannelPrefs $(FINAL_TARGET)/ChannelPrefs.framework
+endif # MOZ_ARTIFACT_BUILDS
+ $(NSINSTALL) $(srcdir)/Info.plist $(FINAL_TARGET)/ChannelPrefs.framework/Resources
+endif # MOZ_WIDGET_TOOLKIT