summaryrefslogtreecommitdiffstats
path: root/toolkit/mozapps/update/updater/macos-frameworks
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-12 05:43:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-12 05:43:14 +0000
commit8dd16259287f58f9273002717ec4d27e97127719 (patch)
tree3863e62a53829a84037444beab3abd4ed9dfc7d0 /toolkit/mozapps/update/updater/macos-frameworks
parentReleasing progress-linux version 126.0.1-1~progress7.99u1. (diff)
downloadfirefox-8dd16259287f58f9273002717ec4d27e97127719.tar.xz
firefox-8dd16259287f58f9273002717ec4d27e97127719.zip
Merging upstream version 127.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'toolkit/mozapps/update/updater/macos-frameworks')
-rw-r--r--toolkit/mozapps/update/updater/macos-frameworks/UpdateSettings-localbuild/Makefile.in25
-rw-r--r--toolkit/mozapps/update/updater/macos-frameworks/UpdateSettings-localbuild/moz.build18
-rw-r--r--toolkit/mozapps/update/updater/macos-frameworks/moz.build7
3 files changed, 49 insertions, 1 deletions
diff --git a/toolkit/mozapps/update/updater/macos-frameworks/UpdateSettings-localbuild/Makefile.in b/toolkit/mozapps/update/updater/macos-frameworks/UpdateSettings-localbuild/Makefile.in
new file mode 100644
index 0000000000..2798eecd64
--- /dev/null
+++ b/toolkit/mozapps/update/updater/macos-frameworks/UpdateSettings-localbuild/Makefile.in
@@ -0,0 +1,25 @@
+# vim:set ts=8 sw=8 sts=8 noet:
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+include $(topsrcdir)/config/rules.mk
+
+# In a compile build, the moz.build stanzas produce a binary named
+# `UpdateSettings-localbuild`. We need to produce
+# `dist/update_framework_artifacts/UpdateSettings-localbuild.framework/UpdateSettings`
+# for consumption by artifact builds.
+#
+# In an artifact build, we already have upstream artifacts in
+# `dist/update_framework_artifacts/UpdateSettings-localbuild.framework`.
+
+ifeq (cocoa,$(MOZ_WIDGET_TOOLKIT))
+libs::
+ifneq (,$(COMPILE_ENVIRONMENT))
+ rm -rf $(FINAL_TARGET)/UpdateSettings-localbuild.framework
+ $(NSINSTALL) -D $(FINAL_TARGET)/UpdateSettings-localbuild.framework
+ cp $(FINAL_TARGET)/UpdateSettings-localbuild UpdateSettings
+ $(NSINSTALL) UpdateSettings $(FINAL_TARGET)/UpdateSettings-localbuild.framework
+endif # COMPILE_ENVIRONMENT
+ $(NSINSTALL) $(srcdir)/../UpdateSettings/Info.plist $(FINAL_TARGET)/UpdateSettings-localbuild.framework/Resources
+endif # MOZ_WIDGET_TOOLKIT
diff --git a/toolkit/mozapps/update/updater/macos-frameworks/UpdateSettings-localbuild/moz.build b/toolkit/mozapps/update/updater/macos-frameworks/UpdateSettings-localbuild/moz.build
new file mode 100644
index 0000000000..ca3a0c9f1c
--- /dev/null
+++ b/toolkit/mozapps/update/updater/macos-frameworks/UpdateSettings-localbuild/moz.build
@@ -0,0 +1,18 @@
+# -*- Mode: python; indent-tabs-mode: nil; tab-width: 40 -*-
+# vim: set filetype=python:
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+Framework("UpdateSettings-localbuild")
+FINAL_TARGET = "dist/update_framework_artifacts"
+
+DEFINES["ACCEPTED_MAR_CHANNEL_IDS"] = '""'
+
+UNIFIED_SOURCES += [
+ "../UpdateSettings/UpdateSettings.mm",
+]
+
+OS_LIBS += [
+ "-framework Foundation",
+]
diff --git a/toolkit/mozapps/update/updater/macos-frameworks/moz.build b/toolkit/mozapps/update/updater/macos-frameworks/moz.build
index 19fa11942e..cb49b680c0 100644
--- a/toolkit/mozapps/update/updater/macos-frameworks/moz.build
+++ b/toolkit/mozapps/update/updater/macos-frameworks/moz.build
@@ -7,7 +7,12 @@
with Files("**"):
BUG_COMPONENT = ("Toolkit", "Application Update")
-DIRS += ["UpdateSettings", "UpdateSettings-xpcshell", "UpdateSettings-WrongChannel"]
+DIRS += [
+ "UpdateSettings",
+ "UpdateSettings-localbuild",
+ "UpdateSettings-WrongChannel",
+ "UpdateSettings-xpcshell",
+]
EXPORTS += [
"UpdateSettingsUtil.h",