summaryrefslogtreecommitdiffstats
path: root/browser/app/nmhproxy/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'browser/app/nmhproxy/Cargo.toml')
-rw-r--r--browser/app/nmhproxy/Cargo.toml17
1 files changed, 17 insertions, 0 deletions
diff --git a/browser/app/nmhproxy/Cargo.toml b/browser/app/nmhproxy/Cargo.toml
new file mode 100644
index 0000000000..14746d51b6
--- /dev/null
+++ b/browser/app/nmhproxy/Cargo.toml
@@ -0,0 +1,17 @@
+[package]
+name = "nmhproxy"
+version = "0.1.0"
+edition = "2021"
+license = "MPL-2.0"
+description = "A lightweight native messaging listener executable for the Firefox Bridge extension which launches Firefox in regular or private modes, avoiding the need to convert Firefox itself into a listener."
+
+[[bin]]
+name = "nmhproxy"
+path = "src/main.rs"
+
+[dependencies]
+mozbuild = "0.1"
+mozilla-central-workspace-hack = { version = "0.1", features = ["nmhproxy"], optional = true }
+serde = { version = "1", features = ["derive", "rc"] }
+serde_json = "1.0"
+url = "2.4"