summaryrefslogtreecommitdiffstats
path: root/build/rust/goblin
diff options
context:
space:
mode:
Diffstat (limited to 'build/rust/goblin')
-rw-r--r--build/rust/goblin/Cargo.toml11
-rw-r--r--build/rust/goblin/lib.rs11
2 files changed, 22 insertions, 0 deletions
diff --git a/build/rust/goblin/Cargo.toml b/build/rust/goblin/Cargo.toml
new file mode 100644
index 0000000000..52e8dfe66d
--- /dev/null
+++ b/build/rust/goblin/Cargo.toml
@@ -0,0 +1,11 @@
+[package]
+name = "goblin"
+version = "0.6.999"
+edition = "2018"
+license = "MIT/Apache-2.0"
+
+[lib]
+path = "lib.rs"
+
+[dependencies.goblin]
+version = "0.7.0"
diff --git a/build/rust/goblin/lib.rs b/build/rust/goblin/lib.rs
new file mode 100644
index 0000000000..ba9ee61592
--- /dev/null
+++ b/build/rust/goblin/lib.rs
@@ -0,0 +1,11 @@
+// Copyright 2014 The Rust Project Developers. See the COPYRIGHT
+// file at the top-level directory of this distribution and at
+// http://rust-lang.org/COPYRIGHT.
+//
+// Licensed under the Apache License, Version 2.0 <LICENSE-APACHE or
+// http://www.apache.org/licenses/LICENSE-2.0> or the MIT license
+// <LICENSE-MIT or http://opensource.org/licenses/MIT>, at your
+// option. This file may not be copied, modified, or distributed
+// except according to those terms.
+
+pub use goblin::*;