summaryrefslogtreecommitdiffstats
path: root/build/rust/memmap2
diff options
context:
space:
mode:
Diffstat (limited to 'build/rust/memmap2')
-rw-r--r--build/rust/memmap2/Cargo.toml11
-rw-r--r--build/rust/memmap2/lib.rs5
2 files changed, 16 insertions, 0 deletions
diff --git a/build/rust/memmap2/Cargo.toml b/build/rust/memmap2/Cargo.toml
new file mode 100644
index 0000000000..eb9ed01134
--- /dev/null
+++ b/build/rust/memmap2/Cargo.toml
@@ -0,0 +1,11 @@
+[package]
+name = "memmap2"
+version = "0.8.999"
+edition = "2018"
+license = "MPL-2.0"
+
+[lib]
+path = "lib.rs"
+
+[dependencies.memmap2]
+version = "0.9"
diff --git a/build/rust/memmap2/lib.rs b/build/rust/memmap2/lib.rs
new file mode 100644
index 0000000000..214110099a
--- /dev/null
+++ b/build/rust/memmap2/lib.rs
@@ -0,0 +1,5 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+pub use memmap2::*;