summaryrefslogtreecommitdiffstats
path: root/build/rust/tinyvec
diff options
context:
space:
mode:
Diffstat (limited to 'build/rust/tinyvec')
-rw-r--r--build/rust/tinyvec/Cargo.toml16
-rw-r--r--build/rust/tinyvec/lib.rs6
2 files changed, 22 insertions, 0 deletions
diff --git a/build/rust/tinyvec/Cargo.toml b/build/rust/tinyvec/Cargo.toml
new file mode 100644
index 0000000000..d40a4db514
--- /dev/null
+++ b/build/rust/tinyvec/Cargo.toml
@@ -0,0 +1,16 @@
+[package]
+name = "tinyvec"
+version = "1.999.999"
+edition = "2018"
+license = "MPL-2.0"
+
+[lib]
+path = "lib.rs"
+
+[dependencies]
+smallvec = "1"
+
+[features]
+alloc = []
+default = []
+std = ["alloc"]
diff --git a/build/rust/tinyvec/lib.rs b/build/rust/tinyvec/lib.rs
new file mode 100644
index 0000000000..decdb0efdc
--- /dev/null
+++ b/build/rust/tinyvec/lib.rs
@@ -0,0 +1,6 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+pub use smallvec::SmallVec as ArrayVec;
+pub use smallvec::SmallVec as TinyVec;