summaryrefslogtreecommitdiffstats
path: root/build/rust
diff options
context:
space:
mode:
Diffstat (limited to 'build/rust')
-rw-r--r--build/rust/backtrace/lib.rs3
-rw-r--r--build/rust/dist-bin/Cargo.toml11
-rw-r--r--build/rust/dist-bin/build.rs16
-rw-r--r--build/rust/dist-bin/lib.rs3
-rw-r--r--build/rust/hashbrown/Cargo.toml19
-rw-r--r--build/rust/hashbrown/lib.rs4
-rw-r--r--build/rust/indexmap/Cargo.toml7
-rw-r--r--build/rust/libloading/Cargo.toml10
-rw-r--r--build/rust/libloading/lib.rs4
-rw-r--r--build/rust/nix/Cargo.toml2
-rw-r--r--build/rust/scroll/Cargo.toml17
-rw-r--r--build/rust/scroll/lib.rs11
12 files changed, 75 insertions, 32 deletions
diff --git a/build/rust/backtrace/lib.rs b/build/rust/backtrace/lib.rs
index e69de29bb2..e0032240a4 100644
--- a/build/rust/backtrace/lib.rs
+++ b/build/rust/backtrace/lib.rs
@@ -0,0 +1,3 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
diff --git a/build/rust/dist-bin/Cargo.toml b/build/rust/dist-bin/Cargo.toml
new file mode 100644
index 0000000000..2bdf076905
--- /dev/null
+++ b/build/rust/dist-bin/Cargo.toml
@@ -0,0 +1,11 @@
+[package]
+name = "dist-bin"
+version = "0.1.0"
+edition = "2021"
+license = "MPL-2.0"
+
+[lib]
+path = "lib.rs"
+
+[build-dependencies]
+mozbuild = "0.1"
diff --git a/build/rust/dist-bin/build.rs b/build/rust/dist-bin/build.rs
new file mode 100644
index 0000000000..5905ee23d4
--- /dev/null
+++ b/build/rust/dist-bin/build.rs
@@ -0,0 +1,16 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+fn main() {
+ // Hack around the lack of dist/bin in the search path set up by
+ // various third party crates for nss. Bug 1892894.
+ println!(
+ "cargo:rustc-link-search=native={}",
+ mozbuild::TOPOBJDIR
+ .join("dist")
+ .join("bin")
+ .to_str()
+ .unwrap()
+ );
+}
diff --git a/build/rust/dist-bin/lib.rs b/build/rust/dist-bin/lib.rs
new file mode 100644
index 0000000000..e0032240a4
--- /dev/null
+++ b/build/rust/dist-bin/lib.rs
@@ -0,0 +1,3 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
diff --git a/build/rust/hashbrown/Cargo.toml b/build/rust/hashbrown/Cargo.toml
new file mode 100644
index 0000000000..be365ea103
--- /dev/null
+++ b/build/rust/hashbrown/Cargo.toml
@@ -0,0 +1,19 @@
+[package]
+name = "hashbrown"
+version = "0.13.999"
+edition = "2021"
+
+[lib]
+path = "lib.rs"
+
+[features]
+# N.B., not using `hashbrown/default` because it includes `hashbrown/allocator-api2`, which we want
+# to avoid.
+default = ["ahash", "inline-more"]
+ahash = ["hashbrown/ahash"]
+inline-more = ["hashbrown/inline-more"]
+raw = ["hashbrown/raw"]
+
+[dependencies.hashbrown]
+version = "0.14.3"
+default-features = false
diff --git a/build/rust/hashbrown/lib.rs b/build/rust/hashbrown/lib.rs
new file mode 100644
index 0000000000..48ed12a3ba
--- /dev/null
+++ b/build/rust/hashbrown/lib.rs
@@ -0,0 +1,4 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+pub use hashbrown::*;
diff --git a/build/rust/indexmap/Cargo.toml b/build/rust/indexmap/Cargo.toml
index de45a4f02d..ea85a5826e 100644
--- a/build/rust/indexmap/Cargo.toml
+++ b/build/rust/indexmap/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "indexmap"
-version = "2.999.999"
+version = "1.999.999"
edition = "2021"
license = "MPL-2.0"
@@ -9,8 +9,9 @@ path = "lib.rs"
[features]
default = ["std"]
-serde = ["indexmap/serde-1"]
+serde = ["indexmap/serde"]
+serde-1 = ["indexmap/serde"]
std = ["indexmap/std"]
[dependencies.indexmap]
-version = "1.9.3"
+version = "2.2.6"
diff --git a/build/rust/libloading/Cargo.toml b/build/rust/libloading/Cargo.toml
new file mode 100644
index 0000000000..18385bc7ac
--- /dev/null
+++ b/build/rust/libloading/Cargo.toml
@@ -0,0 +1,10 @@
+[package]
+name = "libloading"
+version = "0.7.999"
+edition = "2021"
+
+[lib]
+path = "lib.rs"
+
+[dependencies.libloading]
+version = "0.8.3"
diff --git a/build/rust/libloading/lib.rs b/build/rust/libloading/lib.rs
new file mode 100644
index 0000000000..790eef042c
--- /dev/null
+++ b/build/rust/libloading/lib.rs
@@ -0,0 +1,4 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+pub use libloading::*;
diff --git a/build/rust/nix/Cargo.toml b/build/rust/nix/Cargo.toml
index 4ecba71164..b8a704d1a7 100644
--- a/build/rust/nix/Cargo.toml
+++ b/build/rust/nix/Cargo.toml
@@ -8,7 +8,7 @@ license = "MPL-2.0"
path = "lib.rs"
[dependencies.nix]
-version = "0.27"
+version = "0.28"
default-features = false
[features]
diff --git a/build/rust/scroll/Cargo.toml b/build/rust/scroll/Cargo.toml
deleted file mode 100644
index dea2c21fd1..0000000000
--- a/build/rust/scroll/Cargo.toml
+++ /dev/null
@@ -1,17 +0,0 @@
-[package]
-name = "scroll"
-version = "0.11.999"
-edition = "2018"
-license = "MIT/Apache-2.0"
-
-[lib]
-path = "lib.rs"
-
-[dependencies.scroll]
-version = "0.12.0"
-default-features = false
-
-[features]
-default = ["scroll/default"]
-derive = ["scroll/derive"]
-std = ["scroll/std"]
diff --git a/build/rust/scroll/lib.rs b/build/rust/scroll/lib.rs
deleted file mode 100644
index f7d352d6d2..0000000000
--- a/build/rust/scroll/lib.rs
+++ /dev/null
@@ -1,11 +0,0 @@
-// Copyright 2014 The Rust Project Developers. See the COPYRIGHT
-// file at the top-level directory of this distribution and at
-// http://rust-lang.org/COPYRIGHT.
-//
-// Licensed under the Apache License, Version 2.0 <LICENSE-APACHE or
-// http://www.apache.org/licenses/LICENSE-2.0> or the MIT license
-// <LICENSE-MIT or http://opensource.org/licenses/MIT>, at your
-// option. This file may not be copied, modified, or distributed
-// except according to those terms.
-
-pub use scroll::*;