summaryrefslogtreecommitdiffstats
path: root/dom/tests/browser/browser_persist_image_accept.js
diff options
context:
space:
mode:
Diffstat (limited to 'dom/tests/browser/browser_persist_image_accept.js')
-rw-r--r--dom/tests/browser/browser_persist_image_accept.js4
1 files changed, 2 insertions, 2 deletions
diff --git a/dom/tests/browser/browser_persist_image_accept.js b/dom/tests/browser/browser_persist_image_accept.js
index b4648a51ec..21a2096b9d 100644
--- a/dom/tests/browser/browser_persist_image_accept.js
+++ b/dom/tests/browser/browser_persist_image_accept.js
@@ -9,7 +9,7 @@ const TEST_PATH = getRootDirectory(gTestPath).replace(
);
var MockFilePicker = SpecialPowers.MockFilePicker;
-MockFilePicker.init(window);
+MockFilePicker.init(window.browsingContext);
registerCleanupFunction(async function () {
info("Running the cleanup code");
@@ -100,7 +100,7 @@ add_task(async function test_image_download() {
});
let httpOnModifyPromise = TestUtils.topicObserved(
"http-on-modify-request",
- (s, t, d) => {
+ s => {
let channel = s.QueryInterface(Ci.nsIChannel);
let uri = channel.URI && channel.URI.spec;
if (!uri.endsWith("dummy.png")) {