summaryrefslogtreecommitdiffstats
path: root/dom/webidl/DocumentFragment.webidl
diff options
context:
space:
mode:
Diffstat (limited to 'dom/webidl/DocumentFragment.webidl')
-rw-r--r--dom/webidl/DocumentFragment.webidl14
1 files changed, 2 insertions, 12 deletions
diff --git a/dom/webidl/DocumentFragment.webidl b/dom/webidl/DocumentFragment.webidl
index 0b760abd04..5425c3d374 100644
--- a/dom/webidl/DocumentFragment.webidl
+++ b/dom/webidl/DocumentFragment.webidl
@@ -4,8 +4,7 @@
* You can obtain one at http://mozilla.org/MPL/2.0/.
*
* The origin of this IDL file is
- * http://www.w3.org/TR/2012/WD-dom-20120405/#interface-documentfragment
- * http://www.w3.org/TR/2012/WD-selectors-api-20120628/#interface-definitions
+ * https://dom.spec.whatwg.org/#documentfragment
*
* Copyright © 2012 W3C® (MIT, ERCIM, Keio), All Rights Reserved. W3C
* liability, trademark and document use rules apply.
@@ -15,16 +14,7 @@
interface DocumentFragment : Node {
[Throws]
constructor();
-
- Element? getElementById(DOMString elementId);
-};
-
-// http://www.w3.org/TR/2012/WD-selectors-api-20120628/#interface-definitions
-partial interface DocumentFragment {
- [Throws]
- Element? querySelector(UTF8String selectors);
- [Throws]
- NodeList querySelectorAll(UTF8String selectors);
};
DocumentFragment includes ParentNode;
+DocumentFragment includes NonElementParentNode;