summaryrefslogtreecommitdiffstats
path: root/dom/webidl/NonElementParentNode.webidl
diff options
context:
space:
mode:
Diffstat (limited to 'dom/webidl/NonElementParentNode.webidl')
-rw-r--r--dom/webidl/NonElementParentNode.webidl12
1 files changed, 12 insertions, 0 deletions
diff --git a/dom/webidl/NonElementParentNode.webidl b/dom/webidl/NonElementParentNode.webidl
new file mode 100644
index 0000000000..574fb07cc7
--- /dev/null
+++ b/dom/webidl/NonElementParentNode.webidl
@@ -0,0 +1,12 @@
+/* -*- Mode: IDL; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this file,
+ * You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * The origin of this IDL file is
+ * https://dom.spec.whatwg.org/#nonelementparentnode
+ */
+interface mixin NonElementParentNode {
+ [Pure]
+ Element? getElementById(DOMString elementId);
+};