summaryrefslogtreecommitdiffstats
path: root/dom/webidl/UserActivation.webidl
diff options
context:
space:
mode:
Diffstat (limited to 'dom/webidl/UserActivation.webidl')
-rw-r--r--dom/webidl/UserActivation.webidl14
1 files changed, 14 insertions, 0 deletions
diff --git a/dom/webidl/UserActivation.webidl b/dom/webidl/UserActivation.webidl
new file mode 100644
index 0000000000..f8f79c3872
--- /dev/null
+++ b/dom/webidl/UserActivation.webidl
@@ -0,0 +1,14 @@
+/* -*- Mode: IDL; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this file,
+ * You can obtain one at http://mozilla.org/MPL/2.0/.
+ *
+ * The origin of this IDL file is
+ * https://html.spec.whatwg.org/multipage/interaction.html#the-useractivation-interface
+ */
+
+[Exposed=Window]
+interface UserActivation {
+ readonly attribute boolean hasBeenActive;
+ readonly attribute boolean isActive;
+};