summaryrefslogtreecommitdiffstats
path: root/intl/icu_capi/cpp/docs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'intl/icu_capi/cpp/docs/Makefile')
-rw-r--r--intl/icu_capi/cpp/docs/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/intl/icu_capi/cpp/docs/Makefile b/intl/icu_capi/cpp/docs/Makefile
new file mode 100644
index 0000000000..7916981874
--- /dev/null
+++ b/intl/icu_capi/cpp/docs/Makefile
@@ -0,0 +1,25 @@
+# This file is part of ICU4X. For terms of use, please see the file
+# called LICENSE at the top level of the ICU4X source tree
+# (online at: https://github.com/unicode-org/icu4x/blob/main/LICENSE ).
+
+# This file was autogenerated by `sphinx-quickstart`
+
+# Minimal makefile for Sphinx documentation
+
+# You can set these variables from the command line, and also
+# from the environment for the first two.
+SPHINXOPTS ?=
+SPHINXBUILD ?= sphinx-build
+SOURCEDIR = source
+BUILDDIR = build
+
+# Put it first so that "make" without argument is like "make help".
+help:
+ @$(SPHINXBUILD) -M help "$(SOURCEDIR)" "$(BUILDDIR)" $(SPHINXOPTS) $(O)
+
+.PHONY: help Makefile
+
+# Catch-all target: route all unknown targets to Sphinx using the new
+# "make mode" option. $(O) is meant as a shortcut for $(SPHINXOPTS).
+%: Makefile
+ @$(SPHINXBUILD) -M $@ "$(SOURCEDIR)" "$(BUILDDIR)" $(SPHINXOPTS) $(O)