summaryrefslogtreecommitdiffstats
path: root/layout/reftests/css-grid/grid-auto-min-sizing-definite-001.html
diff options
context:
space:
mode:
Diffstat (limited to 'layout/reftests/css-grid/grid-auto-min-sizing-definite-001.html')
-rw-r--r--layout/reftests/css-grid/grid-auto-min-sizing-definite-001.html91
1 files changed, 91 insertions, 0 deletions
diff --git a/layout/reftests/css-grid/grid-auto-min-sizing-definite-001.html b/layout/reftests/css-grid/grid-auto-min-sizing-definite-001.html
new file mode 100644
index 0000000000..ecedf1512f
--- /dev/null
+++ b/layout/reftests/css-grid/grid-auto-min-sizing-definite-001.html
@@ -0,0 +1,91 @@
+<!DOCTYPE HTML>
+<!--
+ Any copyright is dedicated to the Public Domain.
+ http://creativecommons.org/publicdomain/zero/1.0/
+-->
+<html><head>
+ <meta charset="utf-8">
+ <title>CSS Grid Test: 'auto' min-sizing with definite min-width/height</title>
+ <link rel="author" title="Mats Palmgren" href="https://bugzilla.mozilla.org/show_bug.cgi?id=1176775">
+ <link rel="help" href="https://drafts.csswg.org/css-grid/#min-size-auto">
+ <link rel="match" href="grid-auto-min-sizing-definite-001-ref.html">
+ <style type="text/css">
+body,html { color:black; background:white; font-size:12px; padding:0; margin:0; }
+br { clear:both; }
+
+.grid {
+ display: grid;
+ border: 1px dashed silver;
+ grid-template-columns: minmax(auto,0);
+ grid-template-rows: minmax(auto,0) minmax(auto,0);
+ float: left;
+ margin-bottom:20px;
+ align-items: start;
+ justify-items: start;
+}
+.v {
+ writing-mode: vertical-lr;
+ -webkit-writing-mode: vertical-lr;
+}
+.h {
+ writing-mode: horizontal-tb;
+ -webkit-writing-mode: horizontal-tb;
+}
+.bb {
+ box-sizing: border-box;
+}
+
+span {
+ display: block;
+ background: lime;
+ margin: 7px 13px 50% 20%;
+ padding:1px 3px 10% 30%;
+}
+
+span.v {
+ min-height: 30px;
+ min-width: 10px;
+ border-left: 1px solid;
+ border-top: 3px solid;
+}
+
+span.h {
+ min-width: 30px;
+ min-height: 10px;
+ border-left: 3px solid;
+ border-top: 1px solid;
+}
+
+b40 {
+ display: block;
+ width: 40px;
+ height: 40px;
+ border: 1px solid pink;
+}
+
+xx {
+ display: block;
+ background: lime;
+ padding:32px 32px 20% 40%;
+ margin: 0 0 40% 20%;
+}
+
+ </style>
+</head>
+<body>
+
+<div class="grid"><span class="h"><x></x></span></div>
+<div class="grid"><span class="h bb"><x></x></span></div>
+<div class="grid"><span class="h"><x></x></span><span class="h"><x></x></span></div>
+<div class="grid"><span class="h"><b40></b40></span></div>
+<br>
+<div class="grid"><span class="v"><x></x></span></div>
+<div class="grid"><span class="v bb"><x></x></span></div>
+<div class="grid"><span class="v"><x></x></span><span class="v"><x></x></span></div>
+<div class="grid"><span class="v"><b40></b40></span></div>
+
+<div class="grid"><xx class="v"></xx></div>
+<div class="grid v"><xx class="h"></xx></div>
+
+</body>
+</html>