summaryrefslogtreecommitdiffstats
path: root/layout/reftests/text-decoration/underline-block-propagation-2-quirks.html
diff options
context:
space:
mode:
Diffstat (limited to 'layout/reftests/text-decoration/underline-block-propagation-2-quirks.html')
-rw-r--r--layout/reftests/text-decoration/underline-block-propagation-2-quirks.html35
1 files changed, 35 insertions, 0 deletions
diff --git a/layout/reftests/text-decoration/underline-block-propagation-2-quirks.html b/layout/reftests/text-decoration/underline-block-propagation-2-quirks.html
new file mode 100644
index 0000000000..7e32b7581f
--- /dev/null
+++ b/layout/reftests/text-decoration/underline-block-propagation-2-quirks.html
@@ -0,0 +1,35 @@
+<html><head>
+<title>More tests of propagation of text-decoration</title>
+<style>
+textarea { -moz-appearance: none }
+textarea + textarea { margin-left: 10px }
+</style>
+</head>
+<body>
+<!-- t-d should not propagate to the content of a form control -->
+<form style="text-decoration:underline">
+This text should be underlined.<br>
+<textarea rows="2" cols="40">This text should not be underlined.</textarea
+><textarea rows="2" cols="40" style="text-decoration:line-through"
+>This text should be struck out.</textarea>
+<p>This text should also be underlined.</p>
+</form>
+<!-- t-d should propagate from parent elements to table-cells, except
+ not through a table element in quirks mode, per
+ https://quirks.spec.whatwg.org/#the-text-decoration-doesn't-propagate-into-tables-quirk
+ -->
+<div style="text-decoration:underline">
+ <table style="text-decoration:overline">
+ <tr style="text-decoration:line-through">
+ <td>overlined, and struck out</td>
+ </tr>
+ </table>
+</div>
+<!-- t-d on a float itself should apply -->
+<div style="text-decoration:underline">
+ <p>This text should be underlined.</p>
+ <p style="float:left; text-decoration:overline"
+ >This text should be overlined (only).</p>
+</div>
+</body>
+</html>