summaryrefslogtreecommitdiffstats
path: root/layout/style/res/html.css
diff options
context:
space:
mode:
Diffstat (limited to 'layout/style/res/html.css')
-rw-r--r--layout/style/res/html.css14
1 files changed, 10 insertions, 4 deletions
diff --git a/layout/style/res/html.css b/layout/style/res/html.css
index ff58ecd4d1..769ebece45 100644
--- a/layout/style/res/html.css
+++ b/layout/style/res/html.css
@@ -136,7 +136,7 @@ body {
margin: 8px;
}
-p, dl, multicol {
+p, dl {
display: block;
margin-block-start: 1em;
margin-block-end: 1em;
@@ -765,7 +765,7 @@ video > .caption-box {
* The pseudo element won't inherit CSS styles from its direct parent, `::cue`
* would actually inherit styles from video because it's video's pseudo element.
* Therefore, we have to explicitly set some styles which are already defined
- * in its parent element in vtt.jsm.
+ * in its parent element in vtt.sys.mjs.
*/
::cue {
color: rgba(255, 255, 255, 1);
@@ -816,15 +816,21 @@ dialog::backdrop {
background: rgba(0, 0, 0, 0.1);
}
+/* https://html.spec.whatwg.org/#the-marquee-element-2 */
marquee {
- inline-size: -moz-available;
display: inline-block;
+ text-align: initial;
+ overflow: hidden !important;
+
+ /* See https://github.com/whatwg/html/issues/10249 */
+ inline-size: -moz-available;
vertical-align: text-bottom;
- text-align: start;
+ white-space: nowrap;
}
marquee:is([direction="up"], [direction="down"]) {
block-size: 200px;
+ white-space: unset;
}
/* Ruby */