summaryrefslogtreecommitdiffstats
path: root/layout/tables/crashtests/1767364-3.html
diff options
context:
space:
mode:
Diffstat (limited to 'layout/tables/crashtests/1767364-3.html')
-rw-r--r--layout/tables/crashtests/1767364-3.html28
1 files changed, 28 insertions, 0 deletions
diff --git a/layout/tables/crashtests/1767364-3.html b/layout/tables/crashtests/1767364-3.html
new file mode 100644
index 0000000000..b183a4c342
--- /dev/null
+++ b/layout/tables/crashtests/1767364-3.html
@@ -0,0 +1,28 @@
+<html class="reftest-paged">
+<head>
+<title>Testcase bug 1767364 - page breaks & empty thead causing data loss and asserts</title>
+<style>
+ .bb {
+ break-before: page;
+ }
+ .red {
+ border-top: 1px red solid;
+ border-bottom: 1px red solid;
+ }
+ .green {
+ border-top: 1px green solid;
+ border-bottom: 1px green solid;
+ }
+ .blue {
+ border-top: 1px blue solid;
+ border-bottom: 1px blue solid;
+ }
+</style>
+</head>
+<body>
+<div class="bb red">
+<table class="bb green">
+ <thead></thead>
+ <tfoot><td class="blue">data</td></tfoot>
+</table>
+</div>