summaryrefslogtreecommitdiffstats
path: root/mobile/ios
diff options
context:
space:
mode:
Diffstat (limited to 'mobile/ios')
-rw-r--r--mobile/ios/app.mozbuild10
-rw-r--r--mobile/ios/build.mk5
-rw-r--r--mobile/ios/config/mozconfigs/ios-sim/debug3
-rw-r--r--mobile/ios/config/mozconfigs/ios-sim/opt6
-rw-r--r--mobile/ios/config/mozconfigs/ios/debug3
-rw-r--r--mobile/ios/config/mozconfigs/ios/debug-searchfox8
-rw-r--r--mobile/ios/config/mozconfigs/ios/opt5
-rw-r--r--mobile/ios/installer/Makefile.in11
-rw-r--r--mobile/ios/installer/allowed-dupes.mn26
-rw-r--r--mobile/ios/moz.build10
-rw-r--r--mobile/ios/moz.configure16
11 files changed, 103 insertions, 0 deletions
diff --git a/mobile/ios/app.mozbuild b/mobile/ios/app.mozbuild
new file mode 100644
index 0000000000..af3e729a4a
--- /dev/null
+++ b/mobile/ios/app.mozbuild
@@ -0,0 +1,10 @@
+# vim: set filetype=python:
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+include("/toolkit/toolkit.mozbuild")
+
+DIRS += [
+ "/mobile/ios",
+]
diff --git a/mobile/ios/build.mk b/mobile/ios/build.mk
new file mode 100644
index 0000000000..1e0afc0a68
--- /dev/null
+++ b/mobile/ios/build.mk
@@ -0,0 +1,5 @@
+package:
+ $(MAKE) -C mobile/ios/installer
+
+upload:
+ $(MAKE) -C mobile/ios/installer upload
diff --git a/mobile/ios/config/mozconfigs/ios-sim/debug b/mobile/ios/config/mozconfigs/ios-sim/debug
new file mode 100644
index 0000000000..ea0501d224
--- /dev/null
+++ b/mobile/ios/config/mozconfigs/ios-sim/debug
@@ -0,0 +1,3 @@
+. $topsrcdir/mobile/ios/config/mozconfigs/ios-sim/opt
+
+ac_add_options --enable-debug
diff --git a/mobile/ios/config/mozconfigs/ios-sim/opt b/mobile/ios/config/mozconfigs/ios-sim/opt
new file mode 100644
index 0000000000..aeaf6aa0c3
--- /dev/null
+++ b/mobile/ios/config/mozconfigs/ios-sim/opt
@@ -0,0 +1,6 @@
+ac_add_options --enable-project=mobile/ios
+ac_add_options --target=aarch64-apple-ios-sim
+ac_add_options --enable-clang-plugin
+
+. "$topsrcdir/build/mozconfig.cache"
+. "$topsrcdir/build/mozconfig.automation"
diff --git a/mobile/ios/config/mozconfigs/ios/debug b/mobile/ios/config/mozconfigs/ios/debug
new file mode 100644
index 0000000000..279ebb2053
--- /dev/null
+++ b/mobile/ios/config/mozconfigs/ios/debug
@@ -0,0 +1,3 @@
+. $topsrcdir/mobile/ios/config/mozconfigs/ios/opt
+
+ac_add_options --enable-debug
diff --git a/mobile/ios/config/mozconfigs/ios/debug-searchfox b/mobile/ios/config/mozconfigs/ios/debug-searchfox
new file mode 100644
index 0000000000..a027cd8921
--- /dev/null
+++ b/mobile/ios/config/mozconfigs/ios/debug-searchfox
@@ -0,0 +1,8 @@
+MOZ_AUTOMATION_BUILD_SYMBOLS=0
+MOZ_AUTOMATION_CHECK=0
+
+. $topsrcdir/mobile/ios/config/mozconfigs/ios/opt
+
+ac_add_options --enable-debug
+
+ac_add_options --enable-mozsearch-plugin
diff --git a/mobile/ios/config/mozconfigs/ios/opt b/mobile/ios/config/mozconfigs/ios/opt
new file mode 100644
index 0000000000..4cde731827
--- /dev/null
+++ b/mobile/ios/config/mozconfigs/ios/opt
@@ -0,0 +1,5 @@
+ac_add_options --enable-project=mobile/ios
+ac_add_options --enable-clang-plugin
+
+. "$topsrcdir/build/mozconfig.cache"
+. "$topsrcdir/build/mozconfig.automation"
diff --git a/mobile/ios/installer/Makefile.in b/mobile/ios/installer/Makefile.in
new file mode 100644
index 0000000000..1d4c4ff321
--- /dev/null
+++ b/mobile/ios/installer/Makefile.in
@@ -0,0 +1,11 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+STANDALONE_MAKEFILE := 1
+
+include $(topsrcdir)/config/rules.mk
+
+MOZ_PKG_DUPEFLAGS = -f $(srcdir)/allowed-dupes.mn
+
+include $(topsrcdir)/toolkit/mozapps/installer/packager.mk
diff --git a/mobile/ios/installer/allowed-dupes.mn b/mobile/ios/installer/allowed-dupes.mn
new file mode 100644
index 0000000000..078bbe4e09
--- /dev/null
+++ b/mobile/ios/installer/allowed-dupes.mn
@@ -0,0 +1,26 @@
+# Known duplicate files
+# This file is ideally removed, but some existing files will be allowed exceptions
+# See bug 1303184
+#
+# PLEASE DO NOT ADD MORE EXCEPTIONS TO THIS LIST
+#
+
+# Row and column icons are duplicated
+res/table-remove-column-active.gif
+res/table-remove-row-active.gif
+res/table-remove-column-hover.gif
+res/table-remove-row-hover.gif
+res/table-remove-column.gif
+res/table-remove-row.gif
+
+res/multilocale.txt
+update.locale
+
+# Bug 1833829 - Rolling out new search configuration.
+defaults/settings/main/search-config-icons/47da97b5-600f-c450-fd15-a52bb2169c11
+defaults/settings/main/search-config-icons/fed4f021-ff3e-942a-010e-afa43fda2136
+defaults/settings/main/search-config-icons/6a83583a-f0ba-fd39-2fdb-fd2b6990ea3b
+defaults/settings/main/search-config-icons/f312610a-ebfb-a106-ea92-fd643c5d3636
+
+components/httpd.sys.mjs
+chrome/remote/content/server/httpd.sys.mjs
diff --git a/mobile/ios/moz.build b/mobile/ios/moz.build
new file mode 100644
index 0000000000..2253746e12
--- /dev/null
+++ b/mobile/ios/moz.build
@@ -0,0 +1,10 @@
+# -*- Mode: python; indent-tabs-mode: nil; tab-width: 40 -*-
+# vim: set filetype=python:
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+CONFIGURE_SUBST_FILES += ["installer/Makefile"]
+
+with Files("**"):
+ BUG_COMPONENT = ("Core", "General")
diff --git a/mobile/ios/moz.configure b/mobile/ios/moz.configure
new file mode 100644
index 0000000000..b02ed1347e
--- /dev/null
+++ b/mobile/ios/moz.configure
@@ -0,0 +1,16 @@
+# -*- Mode: python; indent-tabs-mode: nil; tab-width: 40 -*-
+# vim: set filetype=python:
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+imply_option("MOZ_PLACES", True)
+
+
+@depends(target)
+def check_target(target):
+ if target.os != "iOS":
+ die("Cannot build mobile/ios with a target other than an iOS one")
+
+
+include("../../toolkit/moz.configure")