summaryrefslogtreecommitdiffstats
path: root/netwerk/socket
diff options
context:
space:
mode:
Diffstat (limited to 'netwerk/socket')
-rw-r--r--netwerk/socket/neqo_glue/Cargo.toml12
-rw-r--r--netwerk/socket/neqo_glue/src/lib.rs30
-rw-r--r--netwerk/socket/nsINamedPipeService.idl4
3 files changed, 22 insertions, 24 deletions
diff --git a/netwerk/socket/neqo_glue/Cargo.toml b/netwerk/socket/neqo_glue/Cargo.toml
index 8355c54c19..dfcd0d8244 100644
--- a/netwerk/socket/neqo_glue/Cargo.toml
+++ b/netwerk/socket/neqo_glue/Cargo.toml
@@ -9,16 +9,16 @@ license = "MPL-2.0"
name = "neqo_glue"
[dependencies]
-neqo-http3 = { tag = "v0.7.5", git = "https://github.com/mozilla/neqo" }
-neqo-transport = { tag = "v0.7.5", git = "https://github.com/mozilla/neqo" }
-neqo-common = { tag = "v0.7.5", git = "https://github.com/mozilla/neqo" }
-neqo-qpack = { tag = "v0.7.5", git = "https://github.com/mozilla/neqo" }
+neqo-http3 = { tag = "v0.7.7", git = "https://github.com/mozilla/neqo" }
+neqo-transport = { tag = "v0.7.7", git = "https://github.com/mozilla/neqo" }
+neqo-common = { tag = "v0.7.7", git = "https://github.com/mozilla/neqo" }
+neqo-qpack = { tag = "v0.7.7", git = "https://github.com/mozilla/neqo" }
nserror = { path = "../../../xpcom/rust/nserror" }
nsstring = { path = "../../../xpcom/rust/nsstring" }
xpcom = { path = "../../../xpcom/rust/xpcom" }
thin-vec = { version = "0.2.1", features = ["gecko-ffi"] }
log = "0.4.0"
-qlog = "0.12"
+qlog = "0.13"
libc = "0.2.0"
static_prefs = { path = "../../../modules/libpref/init/static_prefs"}
uuid = { version = "1.0", features = ["v4"] }
@@ -27,7 +27,7 @@ uuid = { version = "1.0", features = ["v4"] }
winapi = {version = "0.3", features = ["ws2def"] }
[dependencies.neqo-crypto]
-tag = "v0.7.5"
+tag = "v0.7.7"
git = "https://github.com/mozilla/neqo"
default-features = false
features = ["gecko"]
diff --git a/netwerk/socket/neqo_glue/src/lib.rs b/netwerk/socket/neqo_glue/src/lib.rs
index fd527a7fb9..9f11a783be 100644
--- a/netwerk/socket/neqo_glue/src/lib.rs
+++ b/netwerk/socket/neqo_glue/src/lib.rs
@@ -671,11 +671,11 @@ impl From<TransportError> for CloseError {
}
}
-impl From<neqo_transport::ConnectionError> for CloseError {
- fn from(error: neqo_transport::ConnectionError) -> CloseError {
+impl From<neqo_transport::CloseReason> for CloseError {
+ fn from(error: neqo_transport::CloseReason) -> CloseError {
match error {
- neqo_transport::ConnectionError::Transport(c) => c.into(),
- neqo_transport::ConnectionError::Application(c) => CloseError::AppError(c),
+ neqo_transport::CloseReason::Transport(c) => c.into(),
+ neqo_transport::CloseReason::Application(c) => CloseError::AppError(c),
}
}
}
@@ -1056,12 +1056,11 @@ pub extern "C" fn neqo_http3conn_event(
Http3State::Connected => Http3Event::ConnectionConnected,
Http3State::Closing(error_code) => {
match error_code {
- neqo_transport::ConnectionError::Transport(
- TransportError::CryptoError(neqo_crypto::Error::EchRetry(ref c)),
- )
- | neqo_transport::ConnectionError::Transport(TransportError::EchRetry(
- ref c,
- )) => {
+ neqo_transport::CloseReason::Transport(TransportError::CryptoError(
+ neqo_crypto::Error::EchRetry(ref c),
+ ))
+ | neqo_transport::CloseReason::Transport(TransportError::EchRetry(ref c)) =>
+ {
data.extend_from_slice(c.as_ref());
}
_ => {}
@@ -1072,12 +1071,11 @@ pub extern "C" fn neqo_http3conn_event(
}
Http3State::Closed(error_code) => {
match error_code {
- neqo_transport::ConnectionError::Transport(
- TransportError::CryptoError(neqo_crypto::Error::EchRetry(ref c)),
- )
- | neqo_transport::ConnectionError::Transport(TransportError::EchRetry(
- ref c,
- )) => {
+ neqo_transport::CloseReason::Transport(TransportError::CryptoError(
+ neqo_crypto::Error::EchRetry(ref c),
+ ))
+ | neqo_transport::CloseReason::Transport(TransportError::EchRetry(ref c)) =>
+ {
data.extend_from_slice(c.as_ref());
}
_ => {}
diff --git a/netwerk/socket/nsINamedPipeService.idl b/netwerk/socket/nsINamedPipeService.idl
index 9db557577d..ce189ae9d3 100644
--- a/netwerk/socket/nsINamedPipeService.idl
+++ b/netwerk/socket/nsINamedPipeService.idl
@@ -12,7 +12,7 @@
* This is the callback interface for nsINamedPipeService.
* The functions are called by the internal thread in the nsINamedPipeService.
*/
-[scriptable, uuid(de4f460b-94fd-442c-9002-1637beb2185a)]
+[uuid(de4f460b-94fd-442c-9002-1637beb2185a)]
interface nsINamedPipeDataObserver : nsISupports
{
/**
@@ -41,7 +41,7 @@ interface nsINamedPipeDataObserver : nsISupports
/**
* nsINamedPipeService
*/
-[scriptable, uuid(1bf19133-5625-4ac8-836a-80b1c215f72b)]
+[uuid(1bf19133-5625-4ac8-836a-80b1c215f72b)]
interface nsINamedPipeService : nsISupports
{
/**