summaryrefslogtreecommitdiffstats
path: root/other-licenses/snappy/src/README.md
diff options
context:
space:
mode:
Diffstat (limited to 'other-licenses/snappy/src/README.md')
-rw-r--r--other-licenses/snappy/src/README.md33
1 files changed, 29 insertions, 4 deletions
diff --git a/other-licenses/snappy/src/README.md b/other-licenses/snappy/src/README.md
index 8fd7dc09ed..398be7d58a 100644
--- a/other-licenses/snappy/src/README.md
+++ b/other-licenses/snappy/src/README.md
@@ -1,7 +1,6 @@
Snappy, a fast compressor/decompressor.
-[![Build Status](https://travis-ci.org/google/snappy.svg?branch=master)](https://travis-ci.org/google/snappy)
-[![Build status](https://ci.appveyor.com/api/projects/status/t9nubcqkwo8rw8yn/branch/master?svg=true)](https://ci.appveyor.com/project/pwnall/leveldb)
+[![Build Status](https://github.com/google/snappy/actions/workflows/build.yml/badge.svg)](https://github.com/google/snappy/actions/workflows/build.yml)
Introduction
============
@@ -90,13 +89,13 @@ your calling file, and link against the compiled library.
There are many ways to call Snappy, but the simplest possible is
-```cpp
+```c++
snappy::Compress(input.data(), input.size(), &output);
```
and similarly
-```cpp
+```c++
snappy::Uncompress(input.data(), input.size(), &output);
```
@@ -132,6 +131,32 @@ should provide a reasonably balanced starting point for benchmarking. (Note that
baddata[1-3].snappy are not intended as benchmarks; they are used to verify
correctness in the presence of corrupted data in the unit test.)
+Contributing to the Snappy Project
+==================================
+
+In addition to the aims listed at the top of the [README](README.md) Snappy
+explicitly supports the following:
+
+1. C++11
+2. Clang (gcc and MSVC are best-effort).
+3. Low level optimizations (e.g. assembly or equivalent intrinsics) for:
+ 1. [x86](https://en.wikipedia.org/wiki/X86)
+ 2. [x86-64](https://en.wikipedia.org/wiki/X86-64)
+ 3. ARMv7 (32-bit)
+ 4. ARMv8 (AArch64)
+4. Supports only the Snappy compression scheme as described in
+ [format_description.txt](format_description.txt).
+5. CMake for building
+
+Changes adding features or dependencies outside of the core area of focus listed
+above might not be accepted. If in doubt post a message to the
+[Snappy discussion mailing list](https://groups.google.com/g/snappy-compression).
+
+We are unlikely to accept contributions to the build configuration files, such
+as `CMakeLists.txt`. We are focused on maintaining a build configuration that
+allows us to test that the project works in a few supported configurations
+inside Google. We are not currently interested in supporting other requirements,
+such as different operating systems, compilers, or build systems.
Contact
=======