summaryrefslogtreecommitdiffstats
path: root/remote/cdp/targets
diff options
context:
space:
mode:
Diffstat (limited to 'remote/cdp/targets')
-rw-r--r--remote/cdp/targets/TabTarget.sys.mjs4
-rw-r--r--remote/cdp/targets/Target.sys.mjs2
2 files changed, 3 insertions, 3 deletions
diff --git a/remote/cdp/targets/TabTarget.sys.mjs b/remote/cdp/targets/TabTarget.sys.mjs
index a35b0c3f07..016b934cb3 100644
--- a/remote/cdp/targets/TabTarget.sys.mjs
+++ b/remote/cdp/targets/TabTarget.sys.mjs
@@ -94,7 +94,7 @@ export class TabTarget extends Target {
/** @returns {Promise<string|null>} */
get faviconUrl() {
- return new Promise((resolve, reject) => {
+ return new Promise(resolve => {
lazy.Favicons.getFaviconURLForPage(this.browser.currentURI, url => {
if (url) {
resolve(url.spec);
@@ -143,7 +143,7 @@ export class TabTarget extends Target {
// nsIObserver
- observe(subject, topic, data) {
+ observe(subject) {
if (subject === this.mm && subject == "message-manager-disconnect") {
// disconnect debugging target if <browser> is disconnected,
// otherwise this is just a host process change
diff --git a/remote/cdp/targets/Target.sys.mjs b/remote/cdp/targets/Target.sys.mjs
index 9264110c37..ee6353983b 100644
--- a/remote/cdp/targets/Target.sys.mjs
+++ b/remote/cdp/targets/Target.sys.mjs
@@ -21,7 +21,7 @@ export class Target {
*/
constructor(targetList, sessionClass) {
// Save a reference to TargetList instance in order to expose it to:
- // domains/parent/Target.jsm
+ // domains/parent/Target.sys.mjs
this.targetList = targetList;
// When a new connection is made to this target,