summaryrefslogtreecommitdiffstats
path: root/remote/test/puppeteer/test/.eslintrc.js
diff options
context:
space:
mode:
Diffstat (limited to 'remote/test/puppeteer/test/.eslintrc.js')
-rw-r--r--remote/test/puppeteer/test/.eslintrc.js38
1 files changed, 38 insertions, 0 deletions
diff --git a/remote/test/puppeteer/test/.eslintrc.js b/remote/test/puppeteer/test/.eslintrc.js
new file mode 100644
index 0000000000..489868b6ed
--- /dev/null
+++ b/remote/test/puppeteer/test/.eslintrc.js
@@ -0,0 +1,38 @@
+module.exports = {
+ rules: {
+ 'no-restricted-imports': [
+ 'error',
+ {
+ /** The mocha tests run on the compiled output in the /lib directory
+ * so we should avoid importing from src.
+ */
+ patterns: ['*src*'],
+ },
+ ],
+ },
+ overrides: [
+ {
+ files: ['*.spec.ts'],
+ rules: {
+ '@typescript-eslint/no-unused-vars': [
+ 'error',
+ {argsIgnorePattern: '^_', varsIgnorePattern: '^_'},
+ ],
+ 'no-restricted-syntax': [
+ 'error',
+ {
+ message:
+ 'Use helper command `launch` to make sure the browsers get cleaned',
+ selector:
+ 'MemberExpression[object.name="puppeteer"][property.name="launch"]',
+ },
+ {
+ message: 'Unexpected debugging mocha test.',
+ selector:
+ 'CallExpression[callee.object.name="it"] > MemberExpression > Identifier[name="deflake"], CallExpression[callee.object.name="it"] > MemberExpression > Identifier[name="deflakeOnly"]',
+ },
+ ],
+ },
+ },
+ ],
+};