summaryrefslogtreecommitdiffstats
path: root/remote/test/puppeteer/test/installation/src/puppeteer-typescript.spec.ts
diff options
context:
space:
mode:
Diffstat (limited to 'remote/test/puppeteer/test/installation/src/puppeteer-typescript.spec.ts')
-rw-r--r--remote/test/puppeteer/test/installation/src/puppeteer-typescript.spec.ts49
1 files changed, 49 insertions, 0 deletions
diff --git a/remote/test/puppeteer/test/installation/src/puppeteer-typescript.spec.ts b/remote/test/puppeteer/test/installation/src/puppeteer-typescript.spec.ts
new file mode 100644
index 0000000000..fc8ff133fb
--- /dev/null
+++ b/remote/test/puppeteer/test/installation/src/puppeteer-typescript.spec.ts
@@ -0,0 +1,49 @@
+/**
+ * @license
+ * Copyright 2023 Google Inc.
+ * SPDX-License-Identifier: Apache-2.0
+ */
+
+import {readFile, writeFile} from 'fs/promises';
+import {platform} from 'os';
+import {join} from 'path';
+
+import {configureSandbox} from './sandbox.js';
+import {execFile, readAsset} from './util.js';
+
+// Skipping this test on Windows as windows runners are much slower.
+(platform() === 'win32' ? describe.skip : describe)(
+ '`puppeteer` with TypeScript',
+ () => {
+ configureSandbox({
+ dependencies: ['@puppeteer/browsers', 'puppeteer-core', 'puppeteer'],
+ devDependencies: ['typescript@4.7.4', '@types/node@16.3.3'],
+ env: cwd => {
+ return {
+ PUPPETEER_CACHE_DIR: join(cwd, '.cache', 'puppeteer'),
+ };
+ },
+ });
+
+ it('should work', async function () {
+ // Write a Webpack configuration.
+ await writeFile(
+ join(this.sandbox, 'tsconfig.json'),
+ await readAsset('puppeteer', 'tsconfig.json')
+ );
+
+ // Write the source code.
+ await writeFile(
+ join(this.sandbox, 'index.ts'),
+ await readAsset('puppeteer', 'basic.ts')
+ );
+
+ // Compile.
+ await execFile('npx', ['tsc'], {cwd: this.sandbox, shell: true});
+
+ const script = await readFile(join(this.sandbox, 'index.js'), 'utf-8');
+
+ await this.runScript(script, 'cjs');
+ });
+ }
+);