summaryrefslogtreecommitdiffstats
path: root/remote/test/puppeteer/test/src/debugInfo.spec.ts
diff options
context:
space:
mode:
Diffstat (limited to 'remote/test/puppeteer/test/src/debugInfo.spec.ts')
-rw-r--r--remote/test/puppeteer/test/src/debugInfo.spec.ts12
1 files changed, 12 insertions, 0 deletions
diff --git a/remote/test/puppeteer/test/src/debugInfo.spec.ts b/remote/test/puppeteer/test/src/debugInfo.spec.ts
index 079107cab7..4f79231667 100644
--- a/remote/test/puppeteer/test/src/debugInfo.spec.ts
+++ b/remote/test/puppeteer/test/src/debugInfo.spec.ts
@@ -15,6 +15,18 @@ describe('DebugInfo', function () {
it('should work', async () => {
const {page, browser} = await getTestState();
+ for (let i = 0; i < 5; i++) {
+ if (!browser.debugInfo.pendingProtocolErrors.length) {
+ break;
+ }
+ await new Promise(resolve => {
+ return setTimeout(resolve, 200);
+ });
+ }
+
+ // Insure that the previous test are flushed
+ expect(browser.debugInfo.pendingProtocolErrors).toHaveLength(0);
+
const promise = page.evaluate(() => {
return new Promise(resolve => {
// @ts-expect-error another context