summaryrefslogtreecommitdiffstats
path: root/remote/test/puppeteer/test/src/jshandle.spec.ts
diff options
context:
space:
mode:
Diffstat (limited to 'remote/test/puppeteer/test/src/jshandle.spec.ts')
-rw-r--r--remote/test/puppeteer/test/src/jshandle.spec.ts10
1 files changed, 10 insertions, 0 deletions
diff --git a/remote/test/puppeteer/test/src/jshandle.spec.ts b/remote/test/puppeteer/test/src/jshandle.spec.ts
index 28097811e4..0c5de6cde0 100644
--- a/remote/test/puppeteer/test/src/jshandle.spec.ts
+++ b/remote/test/puppeteer/test/src/jshandle.spec.ts
@@ -326,6 +326,16 @@ describe('JSHandle', function () {
'JSHandle@proxy'
);
});
+ it('should work with window subtypes', async () => {
+ const {page} = await getTestState();
+
+ expect((await page.evaluateHandle('window')).toString()).toBe(
+ 'JSHandle@window'
+ );
+ expect((await page.evaluateHandle('globalThis')).toString()).toBe(
+ 'JSHandle@window'
+ );
+ });
});
describe('JSHandle[Symbol.dispose]', () => {