summaryrefslogtreecommitdiffstats
path: root/security/manager/ssl/data_storage/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'security/manager/ssl/data_storage/Cargo.toml')
-rw-r--r--security/manager/ssl/data_storage/Cargo.toml18
1 files changed, 18 insertions, 0 deletions
diff --git a/security/manager/ssl/data_storage/Cargo.toml b/security/manager/ssl/data_storage/Cargo.toml
new file mode 100644
index 0000000000..a90b44c69d
--- /dev/null
+++ b/security/manager/ssl/data_storage/Cargo.toml
@@ -0,0 +1,18 @@
+[package]
+name = "data_storage"
+version = "0.0.1"
+edition = "2021"
+license = "MPL-2.0"
+
+[dependencies]
+byteorder = "1"
+cstr = "0.2"
+firefox-on-glean = { path = "../../../../toolkit/components/glean/api" }
+log = "0.4"
+malloc_size_of_derive = { path = "../../../../xpcom/rust/malloc_size_of_derive" }
+moz_task = { path = "../../../../xpcom/rust/moz_task" }
+nserror = { path = "../../../../xpcom/rust/nserror" }
+nsstring = { path = "../../../../xpcom/rust/nsstring" }
+thin-vec = { version = "0.2.1", features = ["gecko-ffi"] }
+wr_malloc_size_of = { path = "../../../../gfx/wr/wr_malloc_size_of" }
+xpcom = { path = "../../../../xpcom/rust/xpcom" }