summaryrefslogtreecommitdiffstats
path: root/services/sync/modules/engines/tabs.sys.mjs
diff options
context:
space:
mode:
Diffstat (limited to 'services/sync/modules/engines/tabs.sys.mjs')
-rw-r--r--services/sync/modules/engines/tabs.sys.mjs4
1 files changed, 2 insertions, 2 deletions
diff --git a/services/sync/modules/engines/tabs.sys.mjs b/services/sync/modules/engines/tabs.sys.mjs
index 861e051d1a..93747665f2 100644
--- a/services/sync/modules/engines/tabs.sys.mjs
+++ b/services/sync/modules/engines/tabs.sys.mjs
@@ -430,7 +430,7 @@ export const TabProvider = {
.then(iconData => {
thisTab.icon = iconData.uri.spec;
})
- .catch(ex => {
+ .catch(() => {
log.trace(
`Failed to fetch favicon for ${url}`,
thisTab.urlHistory[0]
@@ -503,7 +503,7 @@ TabTracker.prototype = {
}
},
- async observe(subject, topic, data) {
+ async observe(subject, topic) {
switch (topic) {
case "domwindowopened":
let onLoad = () => {