summaryrefslogtreecommitdiffstats
path: root/servo/components/derive_common/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'servo/components/derive_common/Cargo.toml')
-rw-r--r--servo/components/derive_common/Cargo.toml16
1 files changed, 16 insertions, 0 deletions
diff --git a/servo/components/derive_common/Cargo.toml b/servo/components/derive_common/Cargo.toml
new file mode 100644
index 0000000000..b493988026
--- /dev/null
+++ b/servo/components/derive_common/Cargo.toml
@@ -0,0 +1,16 @@
+[package]
+name = "derive_common"
+version = "0.0.1"
+authors = ["The Servo Project Developers"]
+license = "MPL-2.0"
+publish = false
+
+[lib]
+path = "lib.rs"
+
+[dependencies]
+darling = { version = "0.20", default-features = false }
+proc-macro2 = "1"
+quote = "1"
+syn = { version = "2", default-features = false, features = ["clone-impls", "parsing"] }
+synstructure = "0.13"