summaryrefslogtreecommitdiffstats
path: root/servo/components/malloc_size_of/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'servo/components/malloc_size_of/Cargo.toml')
-rw-r--r--servo/components/malloc_size_of/Cargo.toml53
1 files changed, 53 insertions, 0 deletions
diff --git a/servo/components/malloc_size_of/Cargo.toml b/servo/components/malloc_size_of/Cargo.toml
new file mode 100644
index 0000000000..cd5deaea44
--- /dev/null
+++ b/servo/components/malloc_size_of/Cargo.toml
@@ -0,0 +1,53 @@
+[package]
+name = "malloc_size_of"
+version = "0.0.1"
+authors = ["The Servo Project Developers"]
+license = "MIT/Apache-2.0"
+publish = false
+
+[lib]
+path = "lib.rs"
+
+[features]
+servo = [
+ "accountable-refcell",
+ "content-security-policy",
+ "crossbeam-channel",
+ "hyper",
+ "hyper_serde",
+ "keyboard-types",
+ "serde",
+ "serde_bytes",
+ "string_cache",
+ "time",
+ "url",
+ "uuid",
+ "webrender_api",
+ "xml5ever",
+]
+
+[dependencies]
+accountable-refcell = { version = "0.2.0", optional = true }
+app_units = "0.7"
+content-security-policy = { version = "0.4.0", features = ["serde"], optional = true }
+crossbeam-channel = { version = "0.4", optional = true }
+cssparser = "0.33"
+dom = { path = "../../../dom/base/rust" }
+euclid = "0.22"
+hyper = { version = "0.12", optional = true }
+hyper_serde = { version = "0.11", optional = true }
+keyboard-types = { version = "0.4.3", optional = true }
+selectors = { path = "../selectors" }
+serde = { version = "1.0.27", optional = true }
+serde_bytes = { version = "0.11", optional = true }
+servo_arc = { path = "../servo_arc" }
+smallbitvec = "2.3.0"
+smallvec = "1.0"
+string_cache = { version = "0.8", optional = true }
+thin-vec = { version = "0.2.1", features = ["gecko-ffi"] }
+time = { version = "0.1.17", optional = true }
+url = { version = "2.4", optional = true }
+uuid = { version = "0.8", features = ["v4"], optional = true }
+void = "1.0.2"
+webrender_api = { git = "https://github.com/servo/webrender", optional = true }
+xml5ever = { version = "0.16", optional = true }