summaryrefslogtreecommitdiffstats
path: root/storage/rust/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'storage/rust/Cargo.toml')
-rw-r--r--storage/rust/Cargo.toml14
1 files changed, 14 insertions, 0 deletions
diff --git a/storage/rust/Cargo.toml b/storage/rust/Cargo.toml
new file mode 100644
index 0000000000..bf65f94146
--- /dev/null
+++ b/storage/rust/Cargo.toml
@@ -0,0 +1,14 @@
+[package]
+name = "storage"
+description = "Rust bindings for mozStorage."
+version = "0.1.0"
+authors = ["Lina Cambridge <lina@yakshaving.ninja>"]
+edition = "2018"
+license = "MPL-2.0"
+
+[dependencies]
+libc = "0.2"
+nserror = { path = "../../xpcom/rust/nserror" }
+nsstring = { path = "../../xpcom/rust/nsstring" }
+storage_variant = { path = "../variant" }
+xpcom = { path = "../../xpcom/rust/xpcom" }