summaryrefslogtreecommitdiffstats
path: root/testing/condprofile/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'testing/condprofile/Makefile')
-rw-r--r--testing/condprofile/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/condprofile/Makefile b/testing/condprofile/Makefile
new file mode 100644
index 0000000000..b626f5c7e9
--- /dev/null
+++ b/testing/condprofile/Makefile
@@ -0,0 +1,23 @@
+HERE = $(shell pwd)
+BIN = $(HERE)/bin
+PYTHON = $(BIN)/python
+INSTALL = $(BIN)/pip install --no-deps
+BUILD_DIRS = bin build include lib lib64 man share
+VIRTUALENV = virtualenv
+
+.PHONY: all test build docs
+
+all: build
+
+$(PYTHON):
+ $(VIRTUALENV) $(VTENV_OPTS) .
+
+build: $(PYTHON)
+ $(PYTHON) setup.py develop
+ $(BIN)/pip install tox
+
+test: build
+ $(BIN)/tox
+
+docs: build
+ $(BIN)/tox -e docs