summaryrefslogtreecommitdiffstats
path: root/testing/condprofile/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'testing/condprofile/setup.py')
-rw-r--r--testing/condprofile/setup.py32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/condprofile/setup.py b/testing/condprofile/setup.py
new file mode 100644
index 0000000000..0648bff232
--- /dev/null
+++ b/testing/condprofile/setup.py
@@ -0,0 +1,32 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+from setuptools import find_packages, setup
+
+entry_points = """
+ [console_scripts]
+ cp-creator = condprof.main:main
+ cp-client = condprof.client:main
+ """
+
+setup(
+ name="conditioned-profile",
+ version="0.2",
+ packages=find_packages(),
+ description="Firefox Heavy Profile creator",
+ include_package_data=True,
+ data_files=[
+ (
+ "condprof",
+ [
+ "condprof/customization/default.json",
+ "condprof/customization/youtube.json",
+ "condprof/customization/webext.json",
+ ],
+ )
+ ],
+ zip_safe=False,
+ install_requires=[], # use requirements files
+ entry_points=entry_points,
+)