summaryrefslogtreecommitdiffstats
path: root/testing/mozharness/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'testing/mozharness/setup.py')
-rw-r--r--testing/mozharness/setup.py53
1 files changed, 53 insertions, 0 deletions
diff --git a/testing/mozharness/setup.py b/testing/mozharness/setup.py
new file mode 100644
index 0000000000..64fde142fe
--- /dev/null
+++ b/testing/mozharness/setup.py
@@ -0,0 +1,53 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+import os
+from setuptools import setup, find_packages
+
+try:
+ here = os.path.dirname(os.path.abspath(__file__))
+ description = open(os.path.join(here, "README.txt")).read()
+except IOError:
+ description = ""
+
+import mozharness
+
+version = mozharness.version_string
+
+dependencies = [
+ "virtualenv",
+ "mock",
+ "coverage",
+ "pynose",
+ "pylint",
+ "pyflakes",
+ "toml",
+ "tomlkit",
+]
+try:
+ import json
+except ImportError:
+ dependencies.append("simplejson")
+
+setup(
+ name="mozharness",
+ version=version,
+ description="Mozharness is a configuration-driven script harness with full logging that allows production infrastructure and individual developers to use the same scripts. ",
+ long_description=description,
+ classifiers=[
+ "Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: 2 :: Only",
+ ], # Get strings from http://www.python.org/pypi?%3Aaction=list_classifiers
+ author="Aki Sasaki",
+ author_email="aki@mozilla.com",
+ url="https://hg.mozilla.org/build/mozharness/",
+ license="MPL",
+ packages=find_packages(exclude=["ez_setup", "examples", "tests"]),
+ include_package_data=True,
+ zip_safe=False,
+ install_requires=dependencies,
+ entry_points="""
+ # -*- Entry points: -*-
+ """,
+)