summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/flow_control
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/flow_control')
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/flow_control/call.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/flow_control/complex.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/flow_control/eval_order.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/flow_control/for.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/flow_control/if.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/flow_control/loop.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/flow_control/phony.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/flow_control/return.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/flow_control/switch.worker.js6
-rw-r--r--testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/flow_control/while.worker.js6
10 files changed, 60 insertions, 0 deletions
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/flow_control/call.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/flow_control/call.worker.js
new file mode 100644
index 0000000000..03930d032c
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/flow_control/call.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../shader/execution/flow_control/call.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/flow_control/complex.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/flow_control/complex.worker.js
new file mode 100644
index 0000000000..1cd99e11c0
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/flow_control/complex.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../shader/execution/flow_control/complex.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/flow_control/eval_order.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/flow_control/eval_order.worker.js
new file mode 100644
index 0000000000..78b9b84fd3
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/flow_control/eval_order.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../shader/execution/flow_control/eval_order.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/flow_control/for.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/flow_control/for.worker.js
new file mode 100644
index 0000000000..379c29f9ce
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/flow_control/for.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../shader/execution/flow_control/for.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/flow_control/if.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/flow_control/if.worker.js
new file mode 100644
index 0000000000..9b086d3ed7
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/flow_control/if.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../shader/execution/flow_control/if.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/flow_control/loop.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/flow_control/loop.worker.js
new file mode 100644
index 0000000000..bab864b5c3
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/flow_control/loop.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../shader/execution/flow_control/loop.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/flow_control/phony.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/flow_control/phony.worker.js
new file mode 100644
index 0000000000..5badcd1df8
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/flow_control/phony.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../shader/execution/flow_control/phony.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/flow_control/return.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/flow_control/return.worker.js
new file mode 100644
index 0000000000..8e545f3fae
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/flow_control/return.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../shader/execution/flow_control/return.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/flow_control/switch.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/flow_control/switch.worker.js
new file mode 100644
index 0000000000..845493427b
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/flow_control/switch.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../shader/execution/flow_control/switch.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);
diff --git a/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/flow_control/while.worker.js b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/flow_control/while.worker.js
new file mode 100644
index 0000000000..3eae348390
--- /dev/null
+++ b/testing/web-platform/mozilla/tests/webgpu/cts/webworker/shader/execution/flow_control/while.worker.js
@@ -0,0 +1,6 @@
+// AUTO-GENERATED - DO NOT EDIT. See src/common/tools/gen_listings_and_webworkers.ts.
+
+import { g } from '../../../../shader/execution/flow_control/while.spec.js';
+import { wrapTestGroupForWorker } from '../../../../../common/runtime/helper/wrap_for_worker.js';
+
+wrapTestGroupForWorker(g);