summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/console/console-log-large-array.any.js
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/console/console-log-large-array.any.js')
-rw-r--r--testing/web-platform/tests/console/console-log-large-array.any.js8
1 files changed, 8 insertions, 0 deletions
diff --git a/testing/web-platform/tests/console/console-log-large-array.any.js b/testing/web-platform/tests/console/console-log-large-array.any.js
new file mode 100644
index 0000000000..e5cb92d9d3
--- /dev/null
+++ b/testing/web-platform/tests/console/console-log-large-array.any.js
@@ -0,0 +1,8 @@
+// META: global=window,dedicatedworker,shadowrealm
+"use strict";
+// https://console.spec.whatwg.org/
+
+test(() => {
+ console.log(new Array(10000000).fill("x"));
+ console.log(new Uint8Array(10000000));
+}, "Logging large arrays works");