summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/console/console-log-symbol.any.js
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/console/console-log-symbol.any.js')
-rw-r--r--testing/web-platform/tests/console/console-log-symbol.any.js10
1 files changed, 10 insertions, 0 deletions
diff --git a/testing/web-platform/tests/console/console-log-symbol.any.js b/testing/web-platform/tests/console/console-log-symbol.any.js
new file mode 100644
index 0000000000..a2facb6c64
--- /dev/null
+++ b/testing/web-platform/tests/console/console-log-symbol.any.js
@@ -0,0 +1,10 @@
+// META: global=window,dedicatedworker,shadowrealm
+"use strict";
+// https://console.spec.whatwg.org/
+
+test(() => {
+ console.log(Symbol());
+ console.log(Symbol("abc"));
+ console.log(Symbol.for("def"));
+ console.log(Symbol.isConcatSpreadable);
+}, "Logging a symbol doesn't throw");