summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/console/console-number-format-specifiers-symbol-manual.html
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/console/console-number-format-specifiers-symbol-manual.html')
-rw-r--r--testing/web-platform/tests/console/console-number-format-specifiers-symbol-manual.html26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/web-platform/tests/console/console-number-format-specifiers-symbol-manual.html b/testing/web-platform/tests/console/console-number-format-specifiers-symbol-manual.html
new file mode 100644
index 0000000000..f77b84e515
--- /dev/null
+++ b/testing/web-platform/tests/console/console-number-format-specifiers-symbol-manual.html
@@ -0,0 +1,26 @@
+<!DOCTYPE html>
+<html>
+<head>
+<title>Console Number Format Specifiers on Symbols</title>
+<meta name="author" title="Dominic Farolino" href="mailto:domfarolino@gmail.com">
+<meta name="assert" content="Console format specifiers on Symbols">
+<link rel="help" href="https://console.spec.whatwg.org/#formatter">
+</head>
+<body>
+<p>Open the console inside the developer tools. It should contain 15 entries, each of which are:</p>
+<p><code>NaN</code></p>
+
+<script>
+const methods = ["log", "dirxml", "trace", "group", "groupCollapsed"];
+
+for (method of methods) {
+ console[method]("%i", Symbol.for("description"));
+ if (method == "group" || method == "groupCollapsed") console.groupEnd();
+ console[method]("%d", Symbol.for("description"));
+ if (method == "group" || method == "groupCollapsed") console.groupEnd();
+ console[method]("%f", Symbol.for("description"));
+ if (method == "group" || method == "groupCollapsed") console.groupEnd();
+}
+</script>
+</body>
+</html>