summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/console/console-tests-historical.any.js
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/console/console-tests-historical.any.js')
-rw-r--r--testing/web-platform/tests/console/console-tests-historical.any.js20
1 files changed, 20 insertions, 0 deletions
diff --git a/testing/web-platform/tests/console/console-tests-historical.any.js b/testing/web-platform/tests/console/console-tests-historical.any.js
new file mode 100644
index 0000000000..1b18a9879f
--- /dev/null
+++ b/testing/web-platform/tests/console/console-tests-historical.any.js
@@ -0,0 +1,20 @@
+// META: global=window,dedicatedworker,shadowrealm
+/**
+ * These tests assert the non-existence of certain
+ * legacy Console methods that are not included in
+ * the specification: http://console.spec.whatwg.org/
+ */
+
+"use strict";
+
+test(() => {
+ assert_equals(console.timeline, undefined, "console.timeline should be undefined");
+}, "'timeline' function should not exist on the console object");
+
+test(() => {
+ assert_equals(console.timelineEnd, undefined, "console.timelineEnd should be undefined");
+}, "'timelineEnd' function should not exist on the console object");
+
+test(() => {
+ assert_equals(console.markTimeline, undefined, "console.markTimeline should be undefined");
+}, "'markTimeline' function should not exist on the console object");