summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/css/css-lists/li-value-reversed-006e.html
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/css/css-lists/li-value-reversed-006e.html')
-rw-r--r--testing/web-platform/tests/css/css-lists/li-value-reversed-006e.html51
1 files changed, 51 insertions, 0 deletions
diff --git a/testing/web-platform/tests/css/css-lists/li-value-reversed-006e.html b/testing/web-platform/tests/css/css-lists/li-value-reversed-006e.html
new file mode 100644
index 0000000000..e20a32051a
--- /dev/null
+++ b/testing/web-platform/tests/css/css-lists/li-value-reversed-006e.html
@@ -0,0 +1,51 @@
+<!doctype html>
+<title></title>
+<link rel="help" href="https://drafts.csswg.org/css-lists/#instantiating-counters">
+<link rel="help" href="https://html.spec.whatwg.org/#attr-ol-reversed">
+<link rel="help" href="https://github.com/w3c/csswg-drafts/issues/6738">
+<link rel="help" href="https://bugzilla.mozilla.org/show_bug.cgi?id=1706346">
+<link rel="author" title="Mats Palmgren" href="mailto:mats@mozilla.com">
+<link rel="match" href="li-value-reversed-006-ref.html">
+<meta name="assert" content="Reversed value initialization works also for sibling scopes.">
+<style>
+:root {
+ color:black; background-color:white; font:10px/1 monospace;
+}
+ol::before, li::before {
+ content: counters(list-item,".");
+}
+ol[reversed] {
+ margin-bottom: 0;
+}
+ol.no-counter {
+ counter-reset: blah;
+ margin-top: 0;
+}
+ol.no-counter::before {
+ content: none;
+}
+</style>
+<ol reversed></ol>
+<ol class="no-counter">
+ <li style="counter-increment: list-item -2"></li>
+ <li style="counter-increment: list-item -2"></li>
+ <li style="counter-increment: list-item -2"></li>
+</ol>
+<ol reversed></ol>
+<ol class="no-counter">
+ <li style="counter-increment: list-item -3"></li>
+ <li style="counter-increment: list-item -1"></li>
+ <li style="counter-increment: list-item -8"></li>
+</ol>
+<ol reversed></ol>
+<ol class="no-counter">
+ <li style="counter-increment: list-item 2"></li>
+ <li style="counter-increment: list-item 2"></li>
+ <li style="counter-increment: list-item 2"></li>
+</ol>
+<ol reversed></ol>
+<ol class="no-counter">
+ <li style="counter-increment: list-item 3"></li>
+ <li style="counter-increment: list-item 1"></li>
+ <li style="counter-increment: list-item 8"></li>
+</ol>