summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/css/css-scoping/shadow-link-rel-stylesheet-no-style-leak.html
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/css/css-scoping/shadow-link-rel-stylesheet-no-style-leak.html')
-rw-r--r--testing/web-platform/tests/css/css-scoping/shadow-link-rel-stylesheet-no-style-leak.html21
1 files changed, 21 insertions, 0 deletions
diff --git a/testing/web-platform/tests/css/css-scoping/shadow-link-rel-stylesheet-no-style-leak.html b/testing/web-platform/tests/css/css-scoping/shadow-link-rel-stylesheet-no-style-leak.html
new file mode 100644
index 0000000000..8ca69ccd1b
--- /dev/null
+++ b/testing/web-platform/tests/css/css-scoping/shadow-link-rel-stylesheet-no-style-leak.html
@@ -0,0 +1,21 @@
+<!doctype html>
+<title>CSS Test: &lt;link rel="stylesheet"&gt; in Shadow DOM doesn't affect the normal DOM</title>
+<link rel="help" href="https://html.spec.whatwg.org/#link-type-stylesheet">
+<link rel="help" href="https://drafts.csswg.org/css-scoping/#selectors-data-model">
+<link rel="match" href="reference/green-box.html">
+<p>Test passes if you see a single 100px by 100px green box below.</p>
+<style>
+ #light-dom {
+ width: 100px;
+ height: 100px;
+ background: green;
+ color: green;
+ }
+</style>
+<div id="host">FAIL</div>
+<div id="light-dom"></div>
+<script>
+ host.attachShadow({ mode: "open" }).innerHTML = `
+ <link rel="stylesheet" href="data:text/css,div { background: red !important }">
+ `;
+</script>