summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/css/css-scoping/shadow-link-rel-stylesheet.html
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/css/css-scoping/shadow-link-rel-stylesheet.html')
-rw-r--r--testing/web-platform/tests/css/css-scoping/shadow-link-rel-stylesheet.html11
1 files changed, 11 insertions, 0 deletions
diff --git a/testing/web-platform/tests/css/css-scoping/shadow-link-rel-stylesheet.html b/testing/web-platform/tests/css/css-scoping/shadow-link-rel-stylesheet.html
new file mode 100644
index 0000000000..d67929a1ad
--- /dev/null
+++ b/testing/web-platform/tests/css/css-scoping/shadow-link-rel-stylesheet.html
@@ -0,0 +1,11 @@
+<!doctype html>
+<title>CSS Test: &lt;link rel="stylesheet"&gt; in Shadow DOM</title>
+<link rel="help" href="https://html.spec.whatwg.org/#link-type-stylesheet">
+<link rel="match" href="reference/green-box.html">
+<p>Test passes if you see a single 100px by 100px green box below.</p>
+<div id="host">FAIL</div>
+<script>
+ host.attachShadow({ mode: "open" }).innerHTML = `
+ <link rel="stylesheet" href="resources/host-green-box.css">
+ `;
+</script>