summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/css/css-scoping/slotted-matches.html
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/css/css-scoping/slotted-matches.html')
-rw-r--r--testing/web-platform/tests/css/css-scoping/slotted-matches.html16
1 files changed, 16 insertions, 0 deletions
diff --git a/testing/web-platform/tests/css/css-scoping/slotted-matches.html b/testing/web-platform/tests/css/css-scoping/slotted-matches.html
new file mode 100644
index 0000000000..1a582fe98d
--- /dev/null
+++ b/testing/web-platform/tests/css/css-scoping/slotted-matches.html
@@ -0,0 +1,16 @@
+<!doctype html>
+<title>CSS Test: ::slotted() should not match via the matches() API, since it's in the wrong scope</title>
+<script src="/resources/testharness.js"></script>
+<script src="/resources/testharnessreport.js"></script>
+<link rel="author" title="Emilio Cobos Álvarez" href="mailto:emilio@crisal.io">
+<link rel="help" href="https://drafts.csswg.org/css-scoping/#slotted-pseudo">
+<link rel="help" href="https://dom.spec.whatwg.org/#dom-element-matches">
+<link rel="help" href="https://bugzil.la/1544242">
+<div id="host"><div id="slotted"></div></div>
+<script>
+test(function() {
+ let slotted = document.getElementById("slotted");
+ host.attachShadow({ mode: "open" }).innerHTML = `<slot></slot>`;
+ assert_false(slotted.matches("::slotted(div)"), "Shouldn't match ::slotted from the outer tree")
+}, "::slotted() doesn't reveal the presence of shadow DOM via matches()");
+</script>