summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/css/cssom/HTMLLinkElement-disabled-005.html
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/css/cssom/HTMLLinkElement-disabled-005.html')
-rw-r--r--testing/web-platform/tests/css/cssom/HTMLLinkElement-disabled-005.html26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/web-platform/tests/css/cssom/HTMLLinkElement-disabled-005.html b/testing/web-platform/tests/css/cssom/HTMLLinkElement-disabled-005.html
new file mode 100644
index 0000000000..76de206327
--- /dev/null
+++ b/testing/web-platform/tests/css/cssom/HTMLLinkElement-disabled-005.html
@@ -0,0 +1,26 @@
+<!doctype html>
+<title>&lt;link disabled&gt;'s "explicitly enabled" persists across rel changes</title>
+<link rel="author" title="Emilio Cobos Álvarez" href="mailto:emilio@crisal.io">
+<link rel="author" title="Mozilla" href="https://mozilla.org">
+<link rel="help" href="https://html.spec.whatwg.org/#attr-link-disabled">
+<script src="/resources/testharness.js"></script>
+<script src="/resources/testharnessreport.js"></script>
+<link title="alt" rel="yadayada" disabled href="data:text/css,html { background: green }">
+<script>
+function assert_applies(applies) {
+ (applies ? assert_equals : assert_not_equals)(getComputedStyle(document.documentElement).backgroundColor, "rgb(0, 128, 0)");
+}
+
+const link = document.querySelector("link[disabled]");
+
+async_test(function(t) {
+ link.onload = t.step_func_done(function() {
+ assert_applies(true);
+ link.setAttribute("rel", "alternate stylesheet");
+ assert_applies(true);
+ assert_false(link.disabled);
+ });
+ link.disabled = false;
+ link.setAttribute("rel", "stylesheet");
+}, "HTMLLinkElement.disabled's explicitly enabled state persists regardless of rel");
+</script>