summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/custom-elements/prevent-extensions-crash.html
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/custom-elements/prevent-extensions-crash.html')
-rw-r--r--testing/web-platform/tests/custom-elements/prevent-extensions-crash.html15
1 files changed, 15 insertions, 0 deletions
diff --git a/testing/web-platform/tests/custom-elements/prevent-extensions-crash.html b/testing/web-platform/tests/custom-elements/prevent-extensions-crash.html
new file mode 100644
index 0000000000..ae8b96b413
--- /dev/null
+++ b/testing/web-platform/tests/custom-elements/prevent-extensions-crash.html
@@ -0,0 +1,15 @@
+<!DOCTYPE html>
+<meta charset="utf-8">
+<title>Check for crash at step #12 of HTML Constructors</title>
+<meta name='author' href='mailto:masonf@chromium.org'>
+<link rel='help' href='https://html.spec.whatwg.org/multipage/dom.html#html-element-constructors'>
+<link rel='help' href='https://crbug.com/1197894'>
+
+<uh-oh></uh-oh>
+
+<script type="module">
+ Reflect.preventExtensions(document.querySelector('uh-oh'));
+ customElements.define('uh-oh', class extends HTMLElement {});
+</script>
+
+This test passes if it does not crash.