summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/custom-elements/state/custom-state-set-strong-ref.html
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/custom-elements/state/custom-state-set-strong-ref.html')
-rw-r--r--testing/web-platform/tests/custom-elements/state/custom-state-set-strong-ref.html34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/web-platform/tests/custom-elements/state/custom-state-set-strong-ref.html b/testing/web-platform/tests/custom-elements/state/custom-state-set-strong-ref.html
new file mode 100644
index 0000000000..da25943ffa
--- /dev/null
+++ b/testing/web-platform/tests/custom-elements/state/custom-state-set-strong-ref.html
@@ -0,0 +1,34 @@
+<!DOCTYPE html>
+<html>
+ <head>
+ <meta charset="utf-8">
+ <meta name="timeout" content="long">
+ <meta name="author" title="Keith Cirkel" href="mailto:wpt@keithcirkel.co.uk" />
+ <link rel="help" href="https://html.spec.whatwg.org/multipage/custom-elements.html#custom-state-pseudo-class" />
+ <title>CustomStateSet doesn't crash after GC on detached node</title>
+
+ <script src="/resources/testharness.js"></script>
+ <script src="/resources/testharnessreport.js"></script>
+ <script src="/common/gc.js"></script>
+ </head>
+ <body>
+ <custom-state id="myCE"></custom-state>
+ <script>
+ customElements.define('custom-state', class extends HTMLElement {
+ connectedCallback() {
+ this.elementInternals = this.attachInternals();
+ }
+ });
+
+ promise_test(async function() {
+ const states = myCE.elementInternals.states;
+ myCE.remove();
+ await garbageCollect();
+ states.add('still-works');
+ assert_equals(states.size, 1);
+ assert_true(states.delete('still-works'));
+ assert_equals(states.size, 0);
+ }, "customstateset doesn't crash after GC on detached node");
+ </script>
+ </body>
+</html>