summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/dom/events/webkit-animation-iteration-event.html
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/dom/events/webkit-animation-iteration-event.html')
-rw-r--r--testing/web-platform/tests/dom/events/webkit-animation-iteration-event.html23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/web-platform/tests/dom/events/webkit-animation-iteration-event.html b/testing/web-platform/tests/dom/events/webkit-animation-iteration-event.html
new file mode 100644
index 0000000000..fb251972a3
--- /dev/null
+++ b/testing/web-platform/tests/dom/events/webkit-animation-iteration-event.html
@@ -0,0 +1,23 @@
+<!DOCTYPE html>
+<meta charset="utf-8">
+<title>Prefixed CSS Animation iteration events</title>
+<link rel="help" href="https://dom.spec.whatwg.org/#concept-event-listener-invoke">
+
+<script src="/resources/testharness.js"></script>
+<script src="/resources/testharnessreport.js"></script>
+
+<body>
+
+<script src="resources/prefixed-animation-event-tests.js"></script>
+<script>
+'use strict';
+
+runAnimationEventTests({
+ unprefixedType: 'animationiteration',
+ prefixedType: 'webkitAnimationIteration',
+ // Use a long duration to avoid missing the animation due to slow machines,
+ // but set a negative delay so that the iteration boundary happens shortly
+ // after the animation starts.
+ animationCssStyle: '100s -99.9s 2',
+});
+</script>