summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/html/semantics/document-metadata/the-link-element/stylesheet-non-OK-status.html
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/html/semantics/document-metadata/the-link-element/stylesheet-non-OK-status.html')
-rw-r--r--testing/web-platform/tests/html/semantics/document-metadata/the-link-element/stylesheet-non-OK-status.html17
1 files changed, 17 insertions, 0 deletions
diff --git a/testing/web-platform/tests/html/semantics/document-metadata/the-link-element/stylesheet-non-OK-status.html b/testing/web-platform/tests/html/semantics/document-metadata/the-link-element/stylesheet-non-OK-status.html
new file mode 100644
index 0000000000..28ac55ff1a
--- /dev/null
+++ b/testing/web-platform/tests/html/semantics/document-metadata/the-link-element/stylesheet-non-OK-status.html
@@ -0,0 +1,17 @@
+<!DOCTYPE html>
+<meta charset="utf-8">
+<title>stylesheet served with non-OK status</title>
+<link rel="author" title="Michael[tm] Smith" href="mailto:mike@w3.org">
+<link rel="help" href="https://html.spec.whatwg.org/#fetching-and-processing-a-resource-from-a-link-element:processresponseconsumebody">
+<script src="/resources/testharness.js"></script>
+<script src="/resources/testharnessreport.js"></script>
+<script>
+ async_test((t) => {
+ const link = document.createElement("link");
+ link.rel = "stylesheet";
+ link.href = "resources/302-no-Location-header-text-css.asis";
+ link.onload = t.unreached_func();
+ link.onerror = t.step_func_done();
+ document.head.append(link);
+ }, "'load' event does not fire at link@rel=stylesheet having resource with non-OK response status");
+</script>