summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/html/semantics/embedded-content/the-img-element/image-loading-lazy-data-url-to-https.html
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/html/semantics/embedded-content/the-img-element/image-loading-lazy-data-url-to-https.html')
-rw-r--r--testing/web-platform/tests/html/semantics/embedded-content/the-img-element/image-loading-lazy-data-url-to-https.html24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/web-platform/tests/html/semantics/embedded-content/the-img-element/image-loading-lazy-data-url-to-https.html b/testing/web-platform/tests/html/semantics/embedded-content/the-img-element/image-loading-lazy-data-url-to-https.html
new file mode 100644
index 0000000000..809068dd05
--- /dev/null
+++ b/testing/web-platform/tests/html/semantics/embedded-content/the-img-element/image-loading-lazy-data-url-to-https.html
@@ -0,0 +1,24 @@
+<!DOCTYPE html>
+<html class="reftest-wait">
+<head>
+ <title>Lazy loaded Images with data url placeholders can be overwritten by a src change</title>
+ <link rel="help" href="https://html.spec.whatwg.org/multipage/images.html#update-the-image-data">
+ <link rel="match" href="image-loading-lazy-data-url-to-https-ref.html">
+ <script src="/common/reftest-wait.js"></script>
+</head>
+
+<body>
+ <img id="image" loading="lazy" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 872 490' width='872' height='490' style='background: green' %3E%3C/svg%3E">
+
+<script>
+ const image = document.querySelector('#image');
+
+ window.onload = function() {
+ // trigger intersection observer through forced layout.
+ image.offsetWidth;
+ image.setAttribute("src", 'resources/image.png');
+ setTimeout(() => { takeScreenshot(); }, 100);
+ };
+</script>
+</body>
+</html>