summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/html/semantics/popovers/popover-anchor-nested-display.tentative.html
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/html/semantics/popovers/popover-anchor-nested-display.tentative.html')
-rw-r--r--testing/web-platform/tests/html/semantics/popovers/popover-anchor-nested-display.tentative.html56
1 files changed, 56 insertions, 0 deletions
diff --git a/testing/web-platform/tests/html/semantics/popovers/popover-anchor-nested-display.tentative.html b/testing/web-platform/tests/html/semantics/popovers/popover-anchor-nested-display.tentative.html
new file mode 100644
index 0000000000..b60ff49e09
--- /dev/null
+++ b/testing/web-platform/tests/html/semantics/popovers/popover-anchor-nested-display.tentative.html
@@ -0,0 +1,56 @@
+<!DOCTYPE html>
+<meta charset="utf-8">
+<link rel=author href="mailto:xiaochengh@chromium.org">
+<link rel=help href="https://open-ui.org/components/popover.research.explainer">
+<link rel=help href="https://html.spec.whatwg.org/multipage/popover.html">
+<link rel=match href="popover-anchor-nested-display-ref.html">
+
+<button id=main-menu-button popovertarget=main-menu>Show menu</button>
+
+<div id=main-menu popover anchor=main-menu-button>
+ <div>Foo</div>
+ <button id=nested-menu-button popovertarget=nested-menu>
+ Show nested menu
+ </button>
+ <div>Bar</div>
+</div>
+
+<div id=nested-menu popover anchor=nested-menu-button>
+ Baz
+</div>
+
+<style>
+#main-menu-button {
+ position: absolute;
+ top: 200px;
+ left: 100px;
+ width: 100px;
+}
+
+#main-menu {
+ top: anchor(top);
+ left: anchor(right);
+ width: 150px;
+ line-height: 20px;
+}
+
+#nested-menu-button {
+ width: 100%;
+}
+
+#nested-menu {
+ top: anchor(top);
+ left: anchor(right);
+}
+
+[popover] {
+ border: 0;
+ margin: 0;
+ padding: 0;
+}
+</style>
+
+<script>
+document.getElementById('main-menu-button').click();
+document.getElementById('nested-menu-button').click();
+</script>