summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/html/semantics/popovers/popover-dialog-appearance-ref.html
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/html/semantics/popovers/popover-dialog-appearance-ref.html')
-rw-r--r--testing/web-platform/tests/html/semantics/popovers/popover-dialog-appearance-ref.html33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/web-platform/tests/html/semantics/popovers/popover-dialog-appearance-ref.html b/testing/web-platform/tests/html/semantics/popovers/popover-dialog-appearance-ref.html
new file mode 100644
index 0000000000..12efbb6b1e
--- /dev/null
+++ b/testing/web-platform/tests/html/semantics/popovers/popover-dialog-appearance-ref.html
@@ -0,0 +1,33 @@
+<!DOCTYPE html>
+<meta charset="utf-8" />
+<title>Dialog-Popover appearance</title>
+<link rel="author" href="mailto:masonf@chromium.org">
+
+<p>Both dialogs should have the same shades of background.</p>
+<p>The popover should have a completely-transparent ::backdrop.</p>
+<dialog popover id=d1>This is a modal dialog</dialog>
+<dialog popover id=d2>This is a dialog popover</dialog>
+
+<style>
+ dialog {
+ left: 50px;
+ right: auto;
+ bottom: auto;
+ }
+ #d1 {top:100px;}
+ #d2 {top:150px;}
+ /* Force backdrop to spec: */
+ #d1::backdrop {
+ /* https://html.spec.whatwg.org/multipage/rendering.html#flow-content-3 */
+ background-color: rgba(0, 0, 0, 0.1);
+ }
+ #d2::backdrop {
+ /* When shown as a popover, backdrop must be transparent */
+ background-color: transparent;
+ }
+</style>
+
+<script>
+ document.getElementById('d1').showModal();
+ document.getElementById('d2').showPopover();
+</script>