summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/html/syntax/parsing/DOMContentLoaded-defer.html
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/html/syntax/parsing/DOMContentLoaded-defer.html')
-rw-r--r--testing/web-platform/tests/html/syntax/parsing/DOMContentLoaded-defer.html17
1 files changed, 17 insertions, 0 deletions
diff --git a/testing/web-platform/tests/html/syntax/parsing/DOMContentLoaded-defer.html b/testing/web-platform/tests/html/syntax/parsing/DOMContentLoaded-defer.html
new file mode 100644
index 0000000000..44946adf4e
--- /dev/null
+++ b/testing/web-platform/tests/html/syntax/parsing/DOMContentLoaded-defer.html
@@ -0,0 +1,17 @@
+<!doctype html>
+<meta charset=utf-8>
+<title>The end: DOMContentLoaded and defer scripts</title>
+<link rel=help href="https://html.spec.whatwg.org/multipage/#the-end">
+<script src="/resources/testharness.js"></script>
+<script src="/resources/testharnessreport.js"></script>
+<div id="log"></div>
+<script>
+var dcl;
+var t = async_test(function() {
+ dcl = false;
+ document.addEventListener("DOMContentLoaded", function(e) {
+ dcl = true;
+ });
+});
+</script>
+<script defer src=support/DOMContentLoaded-defer.js></script>